[openstack-dev] [Openstack] devstack with neutron/quantum

Sean Dague sean at dague.net
Thu Aug 1 17:49:59 UTC 2013

On 08/01/2013 01:03 PM, Kyle Mestery (kmestery) wrote:
> On Aug 1, 2013, at 11:56 AM, Eleouet Francois <f.eleouet at gmail.com>
>   wrote:
>> Hi,
>> The issue is tracked here: https://bugs.launchpad.net/neutron/+bug/1206013
>> s/cfg.NoSuchOptError/AttributeError/ in neutron/agent/linux/ip_lib.py
>> worked well for me.
> I just replied on another thread for this, but this worked for me too:
> This fixed it for me:
> cd /usr/local/lib/python2.7/dist-packages
> sudo rm -rf oslo*
> sudo pip install --upgrade http://tarballs.openstack.org/oslo.config/oslo.config-1.2.0a3.tar.gz#egg=oslo.config-1.2.0a3

So the right thing to do is get a patch into neutron requirements.txt to 
match the way it is in nova.

That being said, in devstack, this is fixed as of yesterday, as we're 
using oslo.config from git now.

That won't help people not using devstack though.


Sean Dague

More information about the OpenStack-dev mailing list