[openstack-announce] [OSSA 2013-021] Cinder LVM volume driver does not support secure deletion (CVE-2013-4183)

Jeremy Stanley jeremy at openstack.org
Wed Aug 7 15:16:54 UTC 2013

OpenStack Security Advisory: 2013-021
CVE: CVE-2013-4183
Date: August 7, 2013
Title: Cinder LVM volume driver does not support secure deletion
Reporter: Rongze Zhu (UnitedStack)
Products: Cinder
Affects: 2013.1 (Grizzly) and later

Rongze Zhu from UnitedStack reported a vulnerability in the Cinder
LVM volume driver. The contents of LVM snapshots may not be cleared
upon deletion even when secure deletes are configured, resulting in
potential exposure of latent data to subsequent servers for other
tenants. Only setups using LVMVolumeDriver are affected.

Havana (development branch) fix:

Grizzly fix:

This fix is included in the havana-2 development milestone and will
appear in a future 2013.1.3 release.


Jeremy Stanley
OpenStack Vulnerability Management Team
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 966 bytes
Desc: Digital signature
URL: <http://lists.openstack.org/pipermail/openstack-announce/attachments/20130807/95d4e31b/attachment.pgp>

More information about the OpenStack-announce mailing list